GNU Ed Insecure Temporary File Creation Vulnerability

GNU ed creates temporary files in an insecure way.

An attacker with local access could potentially exploit this issue to perform symlink attacks, overwriting arbitrary files in the context of the affected application.

Successfully exploiting a symlink attack may allow an attacker to overwrite or corrupt sensitive files. This may result in a denial of service; other attacks may also be possible.

GNU ed 0.3 and prior versions are vulnerable to this issue.


 

Privacy Statement
Copyright 2010, SecurityFocus