WordPress Post_ID Parameter SQL Injection Vulnerability

Bugtraq ID: 23294
Class: Input Validation Error
CVE: CVE-2007-1897
Remote: Yes
Local: No
Published: Apr 03 2007 12:00AM
Updated: May 02 2007 08:29PM
Credit: sid@notsosecure.com is credited with the discovery of this vulnerability.
Vulnerable: WordPress WordPress 2.1.2
WordPress WordPress 2.1.1
WordPress WordPress 2.0.7
WordPress WordPress 2.0.6
WordPress WordPress 2.0.5
WordPress WordPress 2.0.4
WordPress WordPress 2.0.3
WordPress WordPress 2.0.2
WordPress WordPress 2.0.1
WordPress WordPress 2.0
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 4.0 sparc
Debian Linux 4.0 s/390
Debian Linux 4.0 powerpc
Debian Linux 4.0 mipsel
Debian Linux 4.0 mips
Debian Linux 4.0 m68k
Debian Linux 4.0 ia-64
Debian Linux 4.0 ia-32
Debian Linux 4.0 hppa
Debian Linux 4.0 arm
Debian Linux 4.0 amd64
Debian Linux 4.0 alpha
Debian Linux 4.0
Not Vulnerable: WordPress WordPress 2.1.3
WordPress WordPress 2.0.10


 

Privacy Statement
Copyright 2010, SecurityFocus