MySQL Security Invoker Privilege Escalation Vulnerability

MySQL is prone to a privilege-escalation vulnerability because it fails to adequately restore access privileges during certain routines.

A remote authenticated attacker can exploit this issue to gain elevated privileges on an affected database.

These versions are vulnerable:

MySQL 5 prior to 5.0.40
MySQL 5.1 prior to 5.1.18


 

Privacy Statement
Copyright 2010, SecurityFocus