Festival Insecure Command Local Privilege Escalation and Remote Code Execution Vulnerability

Bugtraq ID: 25069
Class: Design Error
CVE: CVE-2007-4074
Remote: Yes
Local: Yes
Published: Jul 25 2007 12:00AM
Updated: Apr 04 2008 11:08PM
Credit: Konstantine Shirow is credited with the discovery of this issue.
Vulnerable: Ubuntu Ubuntu Linux 7.10 sparc
Ubuntu Ubuntu Linux 7.10 powerpc
Ubuntu Ubuntu Linux 7.10 i386
Ubuntu Ubuntu Linux 7.10 amd64
The Center for Speech Techology Research (CSTR) Festival 1.95 (2.0 beta)
SuSE SUSE Linux Enterprise Server 9
SuSE SUSE Linux Enterprise Server 8
SuSE SUSE Linux Enterprise Server 10
SuSE openSUSE 10.3
SuSE openSUSE 10.2
S.u.S.E. Linux 10.1
S.u.S.E. Linux 10.0
Gentoo app-accessiblity/festival 1.95_beta-r3
Debian Linux 4.0 sparc
Debian Linux 4.0 s/390
Debian Linux 4.0 powerpc
Debian Linux 4.0 mipsel
Debian Linux 4.0 mips
Debian Linux 4.0 m68k
Debian Linux 4.0 ia-64
Debian Linux 4.0 ia-32
Debian Linux 4.0 hppa
Debian Linux 4.0 arm
Debian Linux 4.0 amd64
Debian Linux 4.0 alpha
Debian Linux 4.0
Not Vulnerable: Gentoo app-accessibility/festival 1.95_beta-r4


 

Privacy Statement
Copyright 2010, SecurityFocus