Streamripper HTTP Header Parsing Buffer Overflow Vulnerabilities

Bugtraq ID: 25278
Class: Boundary Condition Error
CVE: CVE-2007-4337
Remote: Yes
Local: No
Published: Aug 12 2007 12:00AM
Updated: Dec 08 2008 11:51PM
Credit: The vendor reported these vulnerabilities.
Vulnerable: Streamripper Streamripper 1.62.1
Streamripper Streamripper 1.62
Streamripper Streamripper 1.61.26
Streamripper Streamripper 1.61.25
Streamripper Streamripper 1.61.24
Streamripper Streamripper 1.61.17
Gentoo Linux
Debian Linux 4.0 sparc
Debian Linux 4.0 s/390
Debian Linux 4.0 powerpc
Debian Linux 4.0 mipsel
Debian Linux 4.0 mips
Debian Linux 4.0 m68k
Debian Linux 4.0 ia-64
Debian Linux 4.0 ia-32
Debian Linux 4.0 hppa
Debian Linux 4.0 arm
Debian Linux 4.0 amd64
Debian Linux 4.0 alpha
Debian Linux 4.0
Not Vulnerable: Streamripper Streamripper 1.62.2


 

Privacy Statement
Copyright 2010, SecurityFocus