Exim Format String Vulnerability

Exim is a free, open-source Mail Transfer Agent for Unix systems.

Exim is vulnerable to a locally exploitable format string attack which may compromise root access. The vulnerability exists only when the 'syntax checking' mode is turned on, which it is not by default.

The vulnerability has to do with handling of the hostname string in an email address argumenting the 'From:' field. If the syntax checking is enabled, then this vulnerability can be exploited to execute arbitrary code with root priviliges.


 

Privacy Statement
Copyright 2010, SecurityFocus