Snoopy '_httpsrequest()' Arbitrary Command Execution Vulnerability

Bugtraq ID: 31887
Class: Input Validation Error
CVE: CVE-2008-4796
Remote: Yes
Local: No
Published: Oct 23 2008 12:00AM
Updated: Dec 14 2009 07:23PM
Credit: This issue was disclosed by the vendor.
Vulnerable: Ubuntu Ubuntu Linux 8.10 sparc
Ubuntu Ubuntu Linux 8.10 powerpc
Ubuntu Ubuntu Linux 8.10 lpia
Ubuntu Ubuntu Linux 8.10 i386
Ubuntu Ubuntu Linux 8.10 amd64
Ubuntu Ubuntu Linux 8.04 LTS sparc
Ubuntu Ubuntu Linux 8.04 LTS powerpc
Ubuntu Ubuntu Linux 8.04 LTS lpia
Ubuntu Ubuntu Linux 8.04 LTS i386
Ubuntu Ubuntu Linux 8.04 LTS amd64
Snoopy Snoopy 1.2.3
Snoopy Snoopy 1.2.1
Snoopy Snoopy 1.2
Snoopy Snoopy 1.0 1
Snoopy Snoopy 0.94
Snoopy Snoopy 0.93
Snoopy Snoopy 0.92
Snoopy Snoopy 0.91
Red Hat Fedora 10
Moodle moodle 1.9.3
Moodle moodle 1.9.3
Moodle moodle 1.8.7
Moodle moodle 1.8.5
Moodle moodle 1.8.4
Moodle moodle 1.8.3
Moodle moodle 1.8.2
Moodle moodle 1.7.6
Moodle moodle 1.7.5
Moodle moodle 1.7.4
Moodle moodle 1.7.3
Moodle moodle 1.7.2
Moodle moodle 1.7.1
Moodle moodle 1.7.1
Moodle moodle 1.6.8
Moodle moodle 1.6.7
Moodle moodle 1.6.6
Moodle moodle 1.6.5
Moodle moodle 1.6.4
Moodle moodle 1.6.3
Moodle moodle 1.6.2
Moodle moodle 1.6.1
Moodle moodle 1.6 dev
Moodle moodle 1.6
Moodle moodle 1.9
Moodle moodle 1.7
Moodle moodle 1.6.1 +
Mahara Mahara 1.0.5
Mahara Mahara 1.0.4
Mahara Mahara 1.0.3
Mahara Mahara 1.0.2
Mahara Mahara 1.0.1
Mahara Mahara 1.0
Debian pixelpost 1.7.1-4
Debian opendb 0.81p20-1.4
Debian opendb 0.81p18-2
Debian mediamate 0.9.3 6-4
Debian mahara 1.0.4-2
Debian Linux 5.0 sparc
Debian Linux 5.0 s/390
Debian Linux 5.0 powerpc
Debian Linux 5.0 mipsel
Debian Linux 5.0 mips
Debian Linux 5.0 m68k
Debian Linux 5.0 ia-64
Debian Linux 5.0 ia-32
Debian Linux 5.0 hppa
Debian Linux 5.0 armel
Debian Linux 5.0 arm
Debian Linux 5.0 amd64
Debian Linux 5.0 alpha
Debian Linux 5.0
Debian Linux 4.0 sparc
Debian Linux 4.0 s/390
Debian Linux 4.0 powerpc
Debian Linux 4.0 mipsel
Debian Linux 4.0 mips
Debian Linux 4.0 m68k
Debian Linux 4.0 ia-64
Debian Linux 4.0 ia-32
Debian Linux 4.0 hppa
Debian Linux 4.0 armel
Debian Linux 4.0 arm
Debian Linux 4.0 amd64
Debian Linux 4.0 alpha
Debian Linux 4.0
Debian libphp-snoopy 1.2.3-2
Debian Ampache 3.4.1-1
Not Vulnerable: Snoopy Snoopy 1.2.4
Moodle moodle 1.9.4
Moodle moodle 1.8.8
Moodle moodle 1.7.7
Moodle moodle 1.6.9
Mahara Mahara 1.0.6
Debian pixelpost 1.7.1-5
Debian mediamate 0.9.3 6-5
Debian mahara 1.0.5-2
Debian libphp-snoopy 1.2.4-1
Debian Ampache 3.4.1-2


 

Privacy Statement
Copyright 2010, SecurityFocus