Net-SNMP 'snmpUDPDomain.c' Remote Information Disclosure Vulnerability

Bugtraq ID: 33755
Class: Access Validation Error
CVE: CVE-2008-6123
Remote: Yes
Local: No
Published: Feb 12 2009 12:00AM
Updated: Jun 02 2010 08:50PM
Credit: Marcel Meckel
Vulnerable: Ubuntu Ubuntu Linux 10.04 sparc
Ubuntu Ubuntu Linux 10.04 powerpc
Ubuntu Ubuntu Linux 10.04 i386
Ubuntu Ubuntu Linux 10.04 amd64
SuSE SUSE Linux Enterprise Server 9 SP3
SuSE SUSE Linux Enterprise Server 9
SuSE SUSE Linux Enterprise Server 11
+ Linux kernel 2.6.5
SuSE SUSE Linux Enterprise Server 10 SP2
SuSE SUSE Linux Enterprise Server 10 SP1
SuSE SUSE Linux Enterprise Server 10
SuSE SUSE Linux Enterprise Desktop 10 SP2
SuSE SUSE Linux Enterprise Desktop 10 SP1
SuSE SUSE Linux Enterprise Desktop 10
SuSE SUSE Linux Enterprise 10 SP2 DEBUGINFO
SuSE SUSE Linux Enterprise 10 SP1 DEBUGINFO
SuSE SUSE Linux Enterprise 10
SuSE openSUSE 10.3
S.u.S.E. SUSE Linux Enterprise Server RT Solution 10 0
S.u.S.E. openSUSE 11.2
S.u.S.E. openSUSE 11.1
S.u.S.E. openSUSE 11.0
RedHat Enterprise Linux WS 5
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Directory Server 8 EL 5
RedHat Directory Server 8 EL 4
RedHat Desktop 3.0
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Red Hat Enterprise Linux 5 Server
Net-SNMP Net-SNMP 5.4.2 1
Net-SNMP Net-SNMP 5.4.1 .1
Net-SNMP Net-SNMP 5.4.1
Net-SNMP Net-SNMP 5.3.2 3
Net-SNMP Net-SNMP 5.3.2 .1
Net-SNMP Net-SNMP 5.3.2
Net-SNMP Net-SNMP 5.3
Net-SNMP Net-SNMP 5.2.5 1
Net-SNMP Net-SNMP 5.2.4 .1
Net-SNMP Net-SNMP 5.2.4
Net-SNMP Net-SNMP 5.2.2
Net-SNMP Net-SNMP 5.2.1 .2
Net-SNMP Net-SNMP 5.2.1
Net-SNMP Net-SNMP 5.2
Net-SNMP Net-SNMP 5.1.4
Net-SNMP Net-SNMP 5.1.3
Net-SNMP Net-SNMP 5.1.2
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Ubuntu Ubuntu Linux 5.0 4 powerpc
+ Ubuntu Ubuntu Linux 5.0 4 i386
+ Ubuntu Ubuntu Linux 5.0 4 amd64
Net-SNMP Net-SNMP 5.1.1
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
Net-SNMP Net-SNMP 5.1
Net-SNMP Net-SNMP 5.0.10 .2
Net-SNMP Net-SNMP 5.0.9
Net-SNMP Net-SNMP 5.0.8
Net-SNMP Net-SNMP 5.0.7
+ Conectiva Linux 9.0
Net-SNMP Net-SNMP 5.0.6
Net-SNMP Net-SNMP 5.0.5
Net-SNMP Net-SNMP 5.0.4 .pre2
+ RedHat Linux 9.0 i386
+ RedHat Linux 8.0 i386
Net-SNMP Net-SNMP 5.0.3
Net-SNMP Net-SNMP 5.0.1
Net-SNMP Net-SNMP 5.3.0.1
Net-SNMP Net-SNMP 0
Mandriva Linux Mandrake 2009.0 x86_64
Mandriva Linux Mandrake 2009.0
Gentoo Linux
Avaya Aura Application Enablement Services 3.1.6
Avaya Aura Application Enablement Services 3.1.5
Avaya Aura Application Enablement Services 3.1.4
Avaya Aura Application Enablement Services 3.1.3
Avaya Aura Application Enablement Services 3.1
Avaya Aura Application Enablement Services 3.0
Not Vulnerable:


 

Privacy Statement
Copyright 2010, SecurityFocus