Adobe Reader 'getAnnots()' JavaScript Function Remote Code Execution Vulnerability

Adobe Reader is prone to a remote code-execution vulnerability.

An attacker can exploit this issue to execute arbitrary code with the privileges of the user running the application or crash the application, denying service to legitimate users.

Reader 8.1.4 and 9.1 for Linux are vulnerable; other versions or platforms may also be affected.

UPDATE (April 28, 2009): The vendor is investigating this issue. We will update this BID as more information emerges.

UPDATE (May 1, 2009): The vendor indicates that fixes will be available by May 12, 2009. Please see the referenced advisory for more information.

UPDATE (May 18, 2009): The vendor indicates that fixes for Adobe Reader 7 for Apple Mac OS X will be available by the end of June, 2009. Please see the updated advisory for more information.


 

Privacy Statement
Copyright 2010, SecurityFocus