'Compress::Raw::Zlib' Perl Module Remote Code Execution Vulnerability

Bugtraq ID: 35307
Class: Design Error
CVE: CVE-2009-1391
Remote: Yes
Local: No
Published: Jun 11 2009 12:00AM
Updated: May 07 2015 05:17PM
Credit: Leo Bergolth
Vulnerable: Ubuntu Ubuntu Linux 9.04 sparc
Ubuntu Ubuntu Linux 9.04 powerpc
Ubuntu Ubuntu Linux 9.04 lpia
Ubuntu Ubuntu Linux 9.04 i386
Ubuntu Ubuntu Linux 9.04 amd64
Ubuntu Ubuntu Linux 8.10 sparc
Ubuntu Ubuntu Linux 8.10 powerpc
Ubuntu Ubuntu Linux 8.10 lpia
Ubuntu Ubuntu Linux 8.10 i386
Ubuntu Ubuntu Linux 8.10 amd64
Ubuntu Ubuntu Linux 8.04 LTS sparc
Ubuntu Ubuntu Linux 8.04 LTS powerpc
Ubuntu Ubuntu Linux 8.04 LTS lpia
Ubuntu Ubuntu Linux 8.04 LTS i386
Ubuntu Ubuntu Linux 8.04 LTS amd64
SuSE SUSE Linux Enterprise Server 9 SP3
SuSE SUSE Linux Enterprise Server 9
SuSE SUSE Linux Enterprise Server 11
+ Linux kernel 2.6.5
SuSE SUSE Linux Enterprise Server 10 SP2
SuSE SUSE Linux Enterprise Server 10 SP1
SuSE SUSE Linux Enterprise Server 10
SuSE SUSE Linux Enterprise Desktop 10 SP2
SuSE SUSE Linux Enterprise Desktop 10 SP1
SuSE SUSE Linux Enterprise Desktop 10
SuSE SUSE Linux Enterprise 10 SP2 DEBUGINFO
SuSE SUSE Linux Enterprise 10 SP1 DEBUGINFO
SuSE openSUSE 10.3
S.u.S.E. SUSE Linux Enterprise Server RT Solution 10 0
S.u.S.E. openSUSE 11.1
S.u.S.E. openSUSE 11.0
Pardus Linux 2008 0
Mandriva Linux Mandrake 2009.1 x86_64
Mandriva Linux Mandrake 2009.1
Mandriva Linux Mandrake 2009.0 x86_64
Mandriva Linux Mandrake 2009.0
Mandriva Linux Mandrake 2008.1 x86_64
Mandriva Linux Mandrake 2008.1
Mandriva Linux Mandrake 2008.0 x86_64
Mandriva Linux Mandrake 2008.0
MandrakeSoft Enterprise Server 5 x86_64
MandrakeSoft Enterprise Server 5
Gentoo Linux
Compress::Raw::Zlib Compress::Raw::Zlib 2.015
Compress::Raw::Zlib Compress::Raw::Zlib 2.014
Activestate ActivePerl 5.10.1
Not Vulnerable: Compress::Raw::Zlib Compress::Raw::Zlib 2.017
Activestate ActivePerl 5.10.1 build 1006


 

Privacy Statement
Copyright 2010, SecurityFocus