Multiple BSD Distributions 'gdtoa/misc.c' Memory Corruption Vulnerability

Multiple BSD distributions are prone to a memory-corruption vulnerability because the software fails to properly bounds-check data used as an array index.

Attackers may exploit this issue to execute arbitrary code within the context of affected applications.

The following are vulnerable:

OpenBSD 4.5
NetBSD 5.0
FreeBSD 6.4 and 7.2

Other software based on the BSD code base may also be affected.


 

Privacy Statement
Copyright 2010, SecurityFocus