aria2 'DHTRoutingTableDeserializer::deserialize()' Buffer Overflow Vulnerability

Bugtraq ID: 36332
Class: Boundary Condition Error
CVE: CVE-2009-3575
Remote: Yes
Local: No
Published: Feb 12 2009 12:00AM
Updated: Jan 14 2010 09:51AM
Credit: Tatsuhiro Tsujikawa
Vulnerable: Tatsuhiro Tsujikawa aria2 1.1.2
Red Hat Fedora 10
Mandriva Linux Mandrake 2009.1 x86_64
Mandriva Linux Mandrake 2009.1
Mandriva Linux Mandrake 2009.0 x86_64
Mandriva Linux Mandrake 2009.0
MandrakeSoft Enterprise Server 5 x86_64
MandrakeSoft Enterprise Server 5
Gentoo Linux
Debian Linux 5.0 sparc
Debian Linux 5.0 s/390
Debian Linux 5.0 powerpc
Debian Linux 5.0 mipsel
Debian Linux 5.0 mips
Debian Linux 5.0 m68k
Debian Linux 5.0 ia-64
Debian Linux 5.0 ia-32
Debian Linux 5.0 hppa
Debian Linux 5.0 armel
Debian Linux 5.0 arm
Debian Linux 5.0 amd64
Debian Linux 5.0 alpha
Debian Linux 5.0
Not Vulnerable: Tatsuhiro Tsujikawa aria2 1.2


 

Privacy Statement
Copyright 2010, SecurityFocus