Quiksoft EasyMail 'AddAttachment()' Method ActiveX Control Buffer Overflow Vulnerability

Quiksoft EasyMail Objects is prone to an unspecified buffer-overflow vulnerability because the application fails to perform adequate boundary checks on user-supplied data.

Successful exploits allow remote attackers to execute arbitrary code in the context of the application (typically Internet Explorer) using the ActiveX control. Failed exploit attempts will likely result in denial-of-service conditions.

EasyMail Objects 6 and 6.0.2.0 are vulnerable; other versions may also be affected.
Spam Inspector 4.0.354 is vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus