nginx 'ngx_http_process_request_headers()' Remote Buffer Overflow Vulnerability

Bugtraq ID: 36839
Class: Boundary Condition Error
CVE: CVE-2009-3896
Remote: Yes
Local: No
Published: Oct 27 2009 12:00AM
Updated: Dec 09 2009 04:14PM
Credit: Jasson Bell
Vulnerable: Red Hat Fedora 12
Red Hat Fedora 11
Red Hat Fedora 10
Igor Sysoev nginx 0.7.61
Igor Sysoev nginx 0.7
Igor Sysoev nginx 0.6.38
Igor Sysoev nginx 0.6.32
Igor Sysoev nginx 0.6
Igor Sysoev nginx 0.5.37
Igor Sysoev nginx 0.5
Igor Sysoev nginx 0.4.14
Igor Sysoev nginx 0.4.13
Igor Sysoev nginx 0.4
Igor Sysoev nginx 0
Debian Linux 5.0 sparc
Debian Linux 5.0 s/390
Debian Linux 5.0 powerpc
Debian Linux 5.0 mipsel
Debian Linux 5.0 mips
Debian Linux 5.0 m68k
Debian Linux 5.0 ia-64
Debian Linux 5.0 ia-32
Debian Linux 5.0 hppa
Debian Linux 5.0 armel
Debian Linux 5.0 arm
Debian Linux 5.0 amd64
Debian Linux 5.0 alpha
Debian Linux 5.0
Debian Linux 4.0 sparc
Debian Linux 4.0 s/390
Debian Linux 4.0 powerpc
Debian Linux 4.0 mipsel
Debian Linux 4.0 mips
Debian Linux 4.0 m68k
Debian Linux 4.0 ia-64
Debian Linux 4.0 ia-32
Debian Linux 4.0 hppa
Debian Linux 4.0 armel
Debian Linux 4.0 arm
Debian Linux 4.0 amd64
Debian Linux 4.0 alpha
Debian Linux 4.0
Not Vulnerable:


 

Privacy Statement
Copyright 2010, SecurityFocus