SystemTap '__get_argv()' and '__get_compat_argv()' Local Memory Corruption Vulnerabilities

Bugtraq ID: 38120
Class: Boundary Condition Error
CVE: CVE-2010-0411
Remote: No
Local: Yes
Published: Feb 05 2010 12:00AM
Updated: Apr 27 2010 04:52PM
Credit: Josh Stone
Vulnerable: SystemTap SystemTap 1.1
SystemTap SystemTap 1.0
S.u.S.E. openSUSE 11.2
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux Desktop version 4
Red Hat Fedora 12
Red Hat Fedora 11
Red Hat Enterprise Linux Desktop 5 client
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux 5 Server
Avaya Messaging Storage Server 5.1
Avaya Messaging Storage Server 5.0
Avaya Messaging Storage Server 4.0
Avaya Messaging Storage Server 3.1 SP1
Not Vulnerable:


 

Privacy Statement
Copyright 2010, SecurityFocus