RETIRED: Adobe Flash Player 10.0.45.2 and AIR 1.5.3.9130 Multiple Remote Vulnerabilities

Adobe Flash Player and AIR are prone to multiple remote vulnerabilities.

An attacker can exploit these issues to execute arbitrary code, cause denial-of-service conditions, or perform cross-site scripting attacks.

This BID is being retired. The following individual records exist to better document the issues:

40779 Adobe Flash Player and AIR (CVE-2010-2160) Unspecified Memory Corruption Vulnerability
40780 Adobe Flash Player and AIR Image Processing Use After Free Remote Code Execution Vulnerability
40781 Adobe Flash Player (CVE-2010-2161) Memory Index Remote Code Execution Vulnerability
40782 Adobe Flash Player and AIR (CVE-2010-2165) Unspecified Memory Corruption Vulnerability
40783 Adobe Flash Player and AIR (CVE-2010-2166) Unspecified Memory Corruption Vulnerability
40784 Adobe Flash Player and AIR (CVE-2010-2171) Unspecified Memory Corruption Vulnerability
40785 Adobe Flash Player and AIR (CVE-2010-2175) Unspecified Memory Corruption Vulnerability
40786 Adobe Flash Player (CVE-2010-2186) Remote Denial of Service Vulnerability
40787 Adobe Flash Player and AIR (CVE-2010-2176) Unspecified Memory Corruption Vulnerability
40788 Adobe Flash Player and AIR (CVE-2010-2177) Unspecified Memory Corruption Vulnerability
40789 Adobe Flash Player (CVE-2010-2170) Integer Overflow Vulnerability
40790 Adobe Flash Player and AIR (CVE-2010-2178) Unspecified Memory Corruption Vulnerability
40791 Adobe Flash Player and AIR (CVE-2010-2180) Unspecified Memory Corruption Vulnerability
40792 Adobe Flash Player (CVE-2010-2181) Integer Overflow Vulnerability
40793 Adobe Flash Player (CVE-2010-2183) Integer Overflow Vulnerability
40794 Adobe Flash Player and AIR (CVE-2010-2182) Unspecified Memory Corruption Vulnerability
40795 Adobe Flash Player (CVE-2010-2172) Remote Denial of Service Vulnerability
40796 Adobe Flash Player and AIR (CVE-2010-2184) Unspecified Memory Corruption Vulnerability
40797 Adobe Flash Player and AIR (CVE-2010-2187) Unspecified Memory Corruption Vulnerability
40798 Adobe Flash Player and AIR (CVE-2010-2188) Unspecified Memory Corruption Vulnerability
40799 Adobe Flash Player and AIR (CVE-2010-2189) Unspecified Memory Corruption Vulnerability
40800 Adobe Flash Player and AIR (CVE-2010-2173) Invalid Pointer Remote Code Execution Vulnerability
40801 Adobe Flash Player (CVE-2010-2162) Heap Memory Corruption Remote Code Execution Vulnerability
40803 Adobe Flash Player (CVE-2010-2163) Multiple Remote Code Execution Vulnerabilities
40802 Adobe Flash Player (CVE-2010-2167) Multiple Heap Buffer Overflow Vulnerabilities
40805 Adobe Flash Player and AIR (CVE-2010-2174) Invalid Pointer Remote Code Execution Vulnerability
40806 Adobe Flash Player and AIR (CVE-2010-2185) Buffer Overflow Vulnerability
40807 Adobe Flash Player and AIR (CVE-2010-2169) Invalid Pointer Remote Memory Corruption Vulnerability
40808 Adobe Flash Player and AIR URI Parsing Cross Site Scripting Vulnerability
40809 Adobe Flash Player (CVE-2009-3793) Remote Code Execution Vulnerability


 

Privacy Statement
Copyright 2010, SecurityFocus