Creative Software AutoUpdate Engine ActiveX Control Buffer Overflow Vulnerability

The Creative Software AutoUpdate Engine ActiveX control is prone to a buffer-overflow vulnerability because the application fails to perform adequate boundary checks on user-supplied data.

Successful exploits allow remote attackers to execute arbitrary code in the context of the application, typically Internet Explorer, using the ActiveX control. Failed exploit attempts will likely result in denial-of-service conditions.

Creative Software AutoUpdate Engine ActiveX control 2.0.12.0 is vulnerable; other versions may be affected.


 

Privacy Statement
Copyright 2010, SecurityFocus