Git 'gitdir' Remote Buffer Overflow Vulnerability

Bugtraq ID: 41891
Class: Boundary Condition Error
CVE: CVE-2010-2542
Remote: Yes
Local: No
Published: Jul 22 2010 12:00AM
Updated: Jan 14 2014 01:21AM
Credit: Greg Brockman
Vulnerable: SuSE SUSE Linux Enterprise 11 SP1
SuSE openSUSE 11.3
Sun Solaris 11 Express
S.u.S.E. openSUSE 11.2
Red Hat Fedora 14
Red Hat Fedora 13
Red Hat Fedora 12
Pardus Linux 2009 0
Mandriva Linux Mandrake 2010.1 x86_64
Mandriva Linux Mandrake 2010.1
Mandriva Linux Mandrake 2010.0 x86_64
Mandriva Linux Mandrake 2010.0
Mandriva Linux Mandrake 2009.1 x86_64
Mandriva Linux Mandrake 2009.1
MandrakeSoft Enterprise Server 5 x86_64
MandrakeSoft Enterprise Server 5
GIT GIT 1.6.3 .2
GIT GIT 1.6 6
GIT GIT 1.6 5
GIT GIT 1.5.6 6
GIT GIT 1.5.6 5
GIT GIT 1.5.6 .4
GIT GIT 1.5.6 .3
GIT GIT 1.5.6
Gentoo Linux
Debian Linux 5.0 sparc
Debian Linux 5.0 s/390
Debian Linux 5.0 powerpc
Debian Linux 5.0 mipsel
Debian Linux 5.0 mips
Debian Linux 5.0 m68k
Debian Linux 5.0 ia-64
Debian Linux 5.0 ia-32
Debian Linux 5.0 hppa
Debian Linux 5.0 armel
Debian Linux 5.0 arm
Debian Linux 5.0 amd64
Debian Linux 5.0 alpha
Debian Linux 5.0
Not Vulnerable: GIT GIT 1.7.2


 

Privacy Statement
Copyright 2010, SecurityFocus