MediaWiki 'api.php' Information Disclosure Vulnerability

Bugtraq ID: 42019
Class: Design Error
CVE: CVE-2010-2787
Remote: Yes
Local: No
Published: Jul 28 2010 12:00AM
Updated: May 07 2015 05:12PM
Credit: Reported by the vendor.
Vulnerable: MediaWiki MediaWiki 1.15.4
MediaWiki MediaWiki 1.15.3
MediaWiki MediaWiki 1.15.2
MediaWiki MediaWiki 1.15.1
MediaWiki MediaWiki 1.15
MediaWiki MediaWiki 1.14.1
MediaWiki MediaWiki 1.14
MediaWiki MediaWiki 1.13.4
MediaWiki MediaWiki 1.13.3
MediaWiki MediaWiki 1.13.2
MediaWiki MediaWiki 1.13.1
MediaWiki MediaWiki 1.13
MediaWiki MediaWiki 1.12.4
MediaWiki MediaWiki 1.12.2
MediaWiki MediaWiki 1.12.1
MediaWiki MediaWiki 1.12
MediaWiki MediaWiki 1.11.2
MediaWiki MediaWiki 1.11.1
MediaWiki MediaWiki 1.11
MediaWiki MediaWiki 1.10.3
MediaWiki MediaWiki 1.10.2
MediaWiki MediaWiki 1.10.1
MediaWiki MediaWiki 1.9.5
MediaWiki MediaWiki 1.9.4
MediaWiki MediaWiki 1.9.3
MediaWiki MediaWiki 1.9.2
MediaWiki MediaWiki 1.9.1
MediaWiki MediaWiki 1.9
MediaWiki MediaWiki 1.8.5
MediaWiki MediaWiki 1.8.4
MediaWiki MediaWiki 1.8.3
MediaWiki MediaWiki 1.8.2
MediaWiki MediaWiki 1.8.1
MediaWiki MediaWiki 1.8
MediaWiki MediaWiki 1.9.0rc2
MediaWiki MediaWiki 1.9.0rc1
MediaWiki MediaWiki 1.12
MediaWiki MediaWiki 1.11.0rc1
MediaWiki MediaWiki 1.11
MediaWiki MediaWiki 1.10
Gentoo Linux
Not Vulnerable: MediaWiki MediaWiki 1.15.5


 

Privacy Statement
Copyright 2010, SecurityFocus