WebKit Geolocation Objects Use-After-Free Remote Code Execution Vulnerability

Bugtraq ID: 44969
Class: Failure to Handle Exceptional Conditions
CVE: CVE-2010-3823
Remote: Yes
Local: No
Published: Nov 18 2010 12:00AM
Updated: Nov 22 2010 06:16PM
Credit: kuzzoc
Vulnerable: WebKit Open Source Project WebKit 0
Apple Safari 4.1.2 for Windows
Apple Safari 4.0.5 for Windows
Apple Safari 4.0.5
Apple Safari 4.0.4 for Windows
Apple Safari 4.0.4
Apple Safari 4.0.3 for Windows
Apple Safari 4.0.3
Apple Safari 4.0.2 for Windows
Apple Safari 4.0.2
Apple Safari 4.0.1
Apple Safari 5.0.2 for Windows
Apple Safari 5.0.2
Apple Safari 5.0.1 for Windows
Apple Safari 5.0.1
Apple Safari 5.0 for Windows
Apple Safari 5.0
Apple Safari 4.1.2
Apple Safari 4.1.1
Apple Safari 4.1
Apple Safari 4 for Windows
Apple Safari 4 Beta
Apple Safari 4
Apple iPhone 4.0.1
Apple iPhone 3.2.1
Apple iPhone 4.1
Apple iPhone 4.0.1 - Ipodtouch
Apple iPhone 4.0.1 - Iphone
Apple iPhone 4.0 - Ipodtouch
Apple iPhone 4.0 - Iphone
Apple iPhone 4.0
Apple iPhone 3.2.1 - Ipad
Apple iPhone 3.2 - Ipodtouch
Apple iPhone 3.2 - Iphone
Apple iPhone 3.2
Apple iOS 4.0.2
Apple iOS 4.0.1
Apple iOS 3.2.2
Apple iOS 3.2.1
Apple iOS 4.1
Apple iOS 4
Apple iOS 3.2
Not Vulnerable: Apple Safari 5.0.3 for Windows
Apple Safari 5.0.3
Apple Safari 4.1.3 for Windows
Apple Safari 4.1.3
Apple iOS 4.2


 

Privacy Statement
Copyright 2010, SecurityFocus