OpenSSL CVE-2012-2131 Encoded ASN.1 Data Incomplete Fix Memory Corruption Vulnerability

Bugtraq ID: 53212
Class: Design Error
CVE: CVE-2012-2131
Remote: Yes
Local: No
Published: Apr 24 2012 12:00AM
Updated: Nov 14 2014 12:59AM
Credit: Red Hat
Vulnerable: Xerox FreeFlow Print Server (FFPS) 73.C0.41
Xerox FreeFlow Print Server (FFPS) 73.B3.61
Ubuntu Ubuntu Linux 8.04 LTS sparc
Ubuntu Ubuntu Linux 8.04 LTS powerpc
Ubuntu Ubuntu Linux 8.04 LTS lpia
Ubuntu Ubuntu Linux 8.04 LTS i386
Ubuntu Ubuntu Linux 8.04 LTS amd64
Ubuntu Ubuntu Linux 11.10 i386
Ubuntu Ubuntu Linux 11.10 amd64
Ubuntu Ubuntu Linux 11.04 powerpc
Ubuntu Ubuntu Linux 11.04 i386
Ubuntu Ubuntu Linux 11.04 ARM
Ubuntu Ubuntu Linux 11.04 amd64
Ubuntu Ubuntu Linux 10.04 sparc
Ubuntu Ubuntu Linux 10.04 powerpc
Ubuntu Ubuntu Linux 10.04 i386
Ubuntu Ubuntu Linux 10.04 ARM
Ubuntu Ubuntu Linux 10.04 amd64
SuSE SUSE Linux Enterprise Server 10 SP3 LTSS
+ Linux kernel 2.6.5
OpenSSL Project OpenSSL 0.9.8v
Mandriva Linux Mandrake 2010.1 x86_64
Mandriva Linux Mandrake 2010.1
Juniper Networks SA700 SSL VPN 0
Juniper Networks SA6500 SSL VPN 0
Juniper Networks SA6500 FIPS 0
Juniper Networks SA6000 FIPS 0
Juniper Networks SA4500 SSL VPN 0
Juniper Networks SA2500 SSL VPN 0
IBM Virtual I/O Server (VIOS) 2.1
IBM Virtual I/O Server (VIOS) 2.2
IBM Virtual I/O Server (VIOS) 2.1
IBM Virtual I/O Server (VIOS) 2.0
IBM Virtual I/O Server 2.1.3
IBM Virtual I/O Server 2.1.2
IBM Tivoli Netcool/OMNIbus 7.3
IBM OS/400 V7R1M0 0
IBM OS/400 V6R1M0
IBM Aix 7.1.1
IBM Aix 7.1
IBM Aix 6.1.7
IBM Aix 6.1.6
IBM AIX 6.1.5
IBM AIX 6.1.4
IBM AIX 6.1.3
IBM AIX 6.1.2
IBM AIX 6.1.1
IBM AIX 5.3.10
IBM AIX 5.3.9
IBM AIX 5.3.8
IBM AIX 5.3.7
IBM AIX 5.3 L
IBM AIX 7.1
IBM AIX 7.1
IBM AIX 6.2
IBM AIX 6.1
IBM AIX 5.3.12
IBM Aix 5.3.12
IBM AIX 5.3.11
IBM AIX 5.3
HP SSL for OpenVMS 1.4-453
HP SSL for OpenVMS 1.4
HP SSL for OpenVMS 1.3
HP HP-UX B.11.31
HP HP-UX B.11.11
Debian Linux 6.0 sparc
Debian Linux 6.0 s/390
Debian Linux 6.0 powerpc
Debian Linux 6.0 mips
Debian Linux 6.0 ia-64
Debian Linux 6.0 ia-32
Debian Linux 6.0 arm
Debian Linux 6.0 amd64
Collax Collax Business Server 5.5
Blue Coat Systems Proxysg 6.2
Blue Coat Systems Intelligence Center 3.2
Blue Coat Systems Intelligence Center 3.1
Balabit syslog-ng Premium Edition 4.0.1
Balabit syslog-ng Premium Edition 4.1.2a
Balabit syslog-ng Premium Edition 4.1
Balabit syslog-ng Premium Edition 4.0.3b
Balabit syslog-ng Premium Edition 4.0.1a
Apple Mac Os X Server 10.7.4
Apple Mac Os X Server 10.7.3
Apple Mac Os X Server 10.7.1
Apple Mac Os X Server 10.7
Apple Mac Os X Server 10.6.8
Apple Mac Os X 10.7.4
Apple Mac Os X 10.7.3
Apple Mac Os X 10.7.2
Apple Mac Os X 10.7.1
Not Vulnerable: OpenSSL Project OpenSSL 0.9.8w
Collax Collax Business Server 5.5.2


 

Privacy Statement
Copyright 2010, SecurityFocus