socat 'xioscan_readline()' Heap Based Buffer Overflow Vulnerability

Bugtraq ID: 53510
Class: Boundary Condition Error
CVE: CVE-2012-0219
Remote: Yes
Local: No
Published: May 14 2012 12:00AM
Updated: May 29 2013 11:44AM
Credit: Johan Thillemann
Vulnerable: socat socat 2.0.0-b4
socat socat 2.0.0-b3
socat socat 2.0.0-b2
socat socat 2.0.0-b1
socat socat 1.7.2.0
Red Hat Fedora 17
Red Hat Fedora 16
MandrakeSoft Enterprise Server 5 x86_64
MandrakeSoft Enterprise Server 5
Gentoo Linux
Not Vulnerable: socat socat 2.0.0-b5
socat socat 1.7.2.1


 

Privacy Statement
Copyright 2010, SecurityFocus