Apple QuickTime Prior To 7.7.2 RLE Files Buffer Overflow Vulnerability

Apple QuickTime is prone to a buffer-overflow vulnerability that may allow remote attackers to execute arbitrary code.

The issue arises when the application handles specially crafted files. Successful exploits may allow attackers to execute arbitrary code in the context of the currently logged-in user; failed exploit attempts will cause denial-of-service conditions.

Versions prior to QuickTime 7.7.2 are vulnerable on Windows 7, Vista and XP.

NOTE: This issue was previously discussed in BID 53547 (Apple QuickTime Prior To 7.7.2 Multiple Arbitrary Code Execution Vulnerabilities), but has been given its own record to better document it.


 

Privacy Statement
Copyright 2010, SecurityFocus