Qt 'QSslSocket::sslErrors()' Certificate Validation Security Weakness

Bugtraq ID: 57162
Class: Design Error
CVE: CVE-2012-6093
Remote: Yes
Local: No
Published: Jan 02 2013 12:00AM
Updated: Apr 13 2015 10:09PM
Credit: Shane Kearns
Vulnerable: Ubuntu Ubuntu Linux 12.04 LTS i386
Ubuntu Ubuntu Linux 12.04 LTS amd64
Ubuntu Ubuntu Linux 11.10 i386
Ubuntu Ubuntu Linux 11.10 amd64
Ubuntu Ubuntu Linux 10.04 sparc
Ubuntu Ubuntu Linux 10.04 powerpc
Ubuntu Ubuntu Linux 10.04 i386
Ubuntu Ubuntu Linux 10.04 ARM
Ubuntu Ubuntu Linux 10.04 amd64
Trolltech Qt 4.6.3
Trolltech Qt 4.6.2
Trolltech Qt 4.6.1
Trolltech Qt 4.6
Trolltech Qt 4.5.2
Trolltech Qt 4.5.1
Trolltech Qt 4.4.3
Trolltech Qt 4.3.3
Trolltech Qt 4.3.2
Trolltech Qt 4.3.1
Trolltech Qt 4.3
Trolltech Qt 4.2.3
Trolltech Qt 4.2.1
Trolltech Qt 4.1.5
Trolltech Qt 4.1.4
Trolltech Qt 4.1
Trolltech Qt 4.0.1
Trolltech Qt 4.7.0
Trolltech Qt 4.5
Trolltech Qt 4.2
Trolltech Qt 4.1
Not Vulnerable:


 

Privacy Statement
Copyright 2010, SecurityFocus