Puppet CVE-2013-1640 Remote Code Execution Vulnerability

Bugtraq ID: 58452
Class: Unknown
CVE: CVE-2013-1640
Remote: Yes
Local: No
Published: Mar 10 2013 12:00AM
Updated: Apr 13 2015 10:06PM
Credit: Puppet Labs
Vulnerable: Ubuntu Ubuntu Linux 12.10
Ubuntu Ubuntu Linux 12.04 LTS amd64
Ubuntu Ubuntu Linux 11.10
SuSE SUSE Linux Enterprise Server for VMware 11 SP2
+ Linux kernel 2.6.5
SuSE SUSE Linux Enterprise Server 11 SP2
+ Linux kernel 2.6.5
SuSE Suse Linux Enterprise Desktop 11 SP2
+ Linux kernel 2.6.5
Redhat OpenStack Folsom 0
Redhat OpenStack Essex 0
Puppetlabs Puppet Enterprise 1.2
Puppetlabs Puppet Enterprise 1.1
Puppetlabs Puppet Enterprise 1.0
Puppetlabs Puppet 2.6.17
Puppetlabs Puppet 2.6.15
Puppetlabs Puppet 2.6.14
Puppetlabs Puppet 2.6.13
Puppetlabs Puppet 2.6.11
Puppetlabs Puppet 2.6.10
Puppetlabs Puppet 2.6
Gentoo Linux
Debian Linux 6.0 sparc
Debian Linux 6.0 s/390
Debian Linux 6.0 powerpc
Debian Linux 6.0 mips
Debian Linux 6.0 ia-64
Debian Linux 6.0 ia-32
Debian Linux 6.0 arm
Debian Linux 6.0 amd64
Not Vulnerable: Puppetlabs Puppet Enterprise 2.7.2
Puppetlabs Puppet Enterprise 1.2.7
Puppetlabs Puppet 3.1.1
Puppetlabs Puppet 2.7.21
Puppetlabs Puppet 2.6.18


 

Privacy Statement
Copyright 2010, SecurityFocus