HAProxy 'tcp-request content' CVE-2013-1912 Buffer Overflow Vulnerability

Bugtraq ID: 58820
Class: Boundary Condition Error
CVE: CVE-2013-1912
Remote: Yes
Local: No
Published: Apr 03 2013 12:00AM
Updated: Jul 12 2013 07:54PM
Credit: Willy Tarreau
Vulnerable: Ubuntu Ubuntu Linux 12.04 LTS i386
Ubuntu Ubuntu Linux 12.04 LTS amd64
Ubuntu Ubuntu Linux 11.10 i386
Ubuntu Ubuntu Linux 11.10 amd64
Red Hat Fedora 17
haproxy haproxy 1.4.21
haproxy haproxy 1.4.20
haproxy haproxy 1.4.20
Gentoo Linux
Debian Linux 6.0 sparc
Debian Linux 6.0 s/390
Debian Linux 6.0 powerpc
Debian Linux 6.0 mips
Debian Linux 6.0 ia-64
Debian Linux 6.0 ia-32
Debian Linux 6.0 arm
Debian Linux 6.0 amd64
CentOS CentOS 6
Not Vulnerable:


 

Privacy Statement
Copyright 2010, SecurityFocus