Libmcrypt Multiple Buffer Overrun Vulnerabilities

Bugtraq ID: 6510
Class: Boundary Condition Error
CVE: CVE-2003-0031
Remote: Yes
Local: No
Published: Jan 03 2003 12:00AM
Updated: Jul 11 2009 07:17PM
Credit: The discovery of this vulnerability is credited to "Ilia A." <ilia@prohost.org>.
Vulnerable: Mcrypt libmcrypt 2.5.3
Mcrypt libmcrypt 2.5.2
+ S.u.S.E. Linux 8.1
Mcrypt libmcrypt 2.5.1 -r4
+ Gentoo Linux 1.4 _rc1
+ Gentoo Linux 1.2
Mcrypt libmcrypt 2.5 .0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
Mcrypt libmcrypt 2.4.20
+ S.u.S.E. Linux 8.0 i386
+ S.u.S.E. Linux 8.0
Mcrypt libmcrypt 2.4.18
+ Conectiva Linux 8.0
Mcrypt libmcrypt 2.4.15
+ S.u.S.E. Linux 7.3 sparc
+ S.u.S.E. Linux 7.3 ppc
+ S.u.S.E. Linux 7.3 i386
+ S.u.S.E. Linux 7.3
Mcrypt libmcrypt 2.4.10
+ S.u.S.E. Linux 7.2 i386
+ S.u.S.E. Linux 7.2
Mcrypt libmcrypt 2.4.9
+ Conectiva Linux 7.0
Mcrypt libmcrypt 2.4.7
+ S.u.S.E. Linux 7.1 x86
+ S.u.S.E. Linux 7.1 ppc
+ S.u.S.E. Linux 7.1 alpha
+ S.u.S.E. Linux 7.1
Not Vulnerable: Mcrypt libmcrypt 2.5.5


 

Privacy Statement
Copyright 2010, SecurityFocus