libmms MMSH Server Response Heap-Based Buffer Overflow Vulnerability

libmms is prone to a heap-based buffer-overflow vulnerability because the application fails to properly bounds-check user-supplied data before copying it into an insufficiently sized buffer.

Successful exploits may allow an attacker to execute arbitrary code with system privileges. Failed attempts will likely cause a denial-of-service condition.

libmms 0.6.3 and prior are vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus