thttpd defang Remote Buffer Overflow Vulnerability

Bugtraq ID: 8906
Class: Boundary Condition Error
CVE: CVE-2003-0899
Remote: Yes
Local: No
Published: Oct 27 2003 12:00AM
Updated: Jul 11 2009 11:56PM
Credit: The disclosure of this issue has been credited to Joel Soderberg and Christer Oberg of Texonet.
Vulnerable: Acme thttpd 2.23 b1
+ S.u.S.E. Linux 8.1
+ S.u.S.E. Linux Personal 9.0
+ S.u.S.E. Linux Personal 8.2
Acme thttpd 2.22
Acme thttpd 2.21 b
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
Acme thttpd 2.21
Acme thttpd 2.20 c
+ Conectiva Linux 9.0
+ S.u.S.E. Linux 8.0
Acme thttpd 2.20 b
+ S.u.S.E. Linux 7.3
Not Vulnerable: Acme thttpd 2.24


 

Privacy Statement
Copyright 2010, SecurityFocus