Linux Kernel Samba Share Local Privilege Elevation Vulnerability

A local privilege escalation vulnerability has been reported to affect the 2.6 Linux kernel.

The issue appears to exist due to a lack of sufficient sanity checks performed when executing a file that is hosted on a remote Samba share. An attacker may exploit this condition to gain elevated privileges, as the setuid/setgid bit of a remote file is honored on the local system.


 

Privacy Statement
Copyright 2010, SecurityFocus