Pidgin CVE 2017-2640 Out of Bounds Write Security Vulnerability

Bugtraq ID: 96775
Class: Boundary Condition Error
CVE: CVE-2017-2640
Remote: Yes
Local: No
Published: Mar 09 2017 12:00AM
Updated: Jun 07 2017 10:02AM
Credit: Joseph Bisch
Vulnerable: Ubuntu Ubuntu Linux 14.04 LTS
Ubuntu Ubuntu Linux 12.04 LTS
Redhat Enterprise Linux 7
Redhat Enterprise Linux 6
+ Trustix Secure Enterprise Linux 2.0
+ Trustix Secure Linux 2.2
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.0
Redhat Enterprise Linux 5
Pidgin Pidgin 2.10.9
Pidgin Pidgin 2.10.5
Pidgin Pidgin 2.10.4
Pidgin Pidgin 2.10.3
Pidgin Pidgin 2.10.2
Pidgin Pidgin 2.10.1
Pidgin Pidgin 2.9
Pidgin Pidgin 2.8
Pidgin Pidgin 2.7.10
Pidgin Pidgin 2.7.7
Pidgin Pidgin 2.7.6
Pidgin Pidgin 2.7.5
Pidgin Pidgin 2.7.4
Pidgin Pidgin 2.7.3
Pidgin Pidgin 2.7.2
Pidgin Pidgin 2.7.1
Pidgin Pidgin 2.7
Pidgin Pidgin 2.6.6
Pidgin Pidgin 2.6.5
Pidgin Pidgin 2.6.4
Pidgin Pidgin 2.6.3
Pidgin Pidgin 2.6.1
Pidgin Pidgin 2.6
Pidgin Pidgin 2.5.9
Pidgin Pidgin 2.5.8
Pidgin Pidgin 2.5.7
Pidgin Pidgin 2.5.6
Pidgin Pidgin 2.5.5
Pidgin Pidgin 2.4.3
Pidgin Pidgin 2.4.2
Pidgin Pidgin 2.4.1
Pidgin Pidgin 2.4
Pidgin Pidgin 2.2.2
Pidgin Pidgin 2.2.1
Pidgin Pidgin 2.2
Pidgin Pidgin 2.1
Pidgin Pidgin 2.0.2
Pidgin Pidgin 2.0
Pidgin Pidgin 2.7.9
Pidgin Pidgin 2.7.8
Pidgin Pidgin 2.7.11
Pidgin Pidgin 2.6.2
Pidgin Pidgin 2.5.4
Pidgin Pidgin 2.5.3
Pidgin Pidgin 2.5.2
Pidgin Pidgin 2.5.1
Pidgin Pidgin 2.5.0
Pidgin Pidgin 2.3.1
Pidgin Pidgin 2.3.0
Pidgin Pidgin 2.11.0
Pidgin Pidgin 2.10.8
Pidgin Pidgin 2.10.7
Pidgin Pidgin 2.10.6
Pidgin Pidgin 2.10.10
Pidgin Pidgin 2.10.0
Pidgin Pidgin 2.1.1
Pidgin Pidgin 2.0.1
Pidgin Libpurple -
openSUSE Leap 42.2
Gentoo Linux
Debian Linux 6.0 sparc
Debian Linux 6.0 s/390
Debian Linux 6.0 powerpc
Debian Linux 6.0 mips
Debian Linux 6.0 ia-64
Debian Linux 6.0 ia-32
Debian Linux 6.0 ia-30
Debian Linux 6.0 arm
Debian Linux 6.0 amd64
Not Vulnerable: Pidgin Pidgin 2.12.0


 

Privacy Statement
Copyright 2010, SecurityFocus