Linux Kernel do_mremap Function VMA Limit Local Privilege Escalation Vulnerability

Bugtraq ID: 9686
Class: Failure to Handle Exceptional Conditions
CVE: CVE-2004-0077
Remote: No
Local: Yes
Published: Feb 18 2004 12:00AM
Updated: Aug 05 2010 07:45PM
Credit: The disclosure of this issue has been credited to Paul Starzetz <ihaquer@isec.pl>.
Vulnerable: VMWare ESX Server 2.0.1
VMWare ESX Server 2.0
VMWare ESX Server 1.5.2
Trustix Secure Linux 2.0
Trustix Secure Linux 1.5
SmoothWall Express 2.0
SmoothWall Corporate Server 0.3 (Fixes7)
SmoothWall Corporate Guardian 0.3 (Fixes2)
SGI ProPack 2.4
Redhat kernel-source-2.4.20-8.i386.rpm
Redhat kernel-smp-2.4.20-8.i686.rpm
Redhat kernel-smp-2.4.20-8.athlon.rpm
Redhat kernel-doc-2.4.20-8.i386.rpm
Redhat kernel-BOOT-2.4.20-8.i386.rpm
Redhat kernel-bigmem-2.4.20-8.i686.rpm
Redhat kernel-2.4.20-8.i686.rpm
Redhat kernel-2.4.20-8.i386.rpm
Redhat kernel-2.4.20-8.athlon.rpm
Netwosix Netwosix Linux 1.0
Linux kernel 2.6.2
Linux kernel 2.6.1 -rc2
Linux kernel 2.6.1 -rc1
Linux kernel 2.6 -test9-CVS
Linux kernel 2.6 -test9
Linux kernel 2.6 -test8
Linux kernel 2.6 -test7
Linux kernel 2.6 -test6
Linux kernel 2.6 -test5
Linux kernel 2.6 -test4
Linux kernel 2.6 -test3
Linux kernel 2.6 -test2
Linux kernel 2.6 -test11
Linux kernel 2.6 -test10
Linux kernel 2.6 -test1
Linux kernel 2.6
Linux kernel 2.4.24
Linux kernel 2.4.23 -pre9
Linux kernel 2.4.23
Linux kernel 2.4.22
Linux kernel 2.4.21 pre7
Linux kernel 2.4.21 pre4
Linux kernel 2.4.21 pre1
Linux kernel 2.4.21
Linux kernel 2.4.20
Linux kernel 2.4.19 -pre6
Linux kernel 2.4.19 -pre5
Linux kernel 2.4.19 -pre4
Linux kernel 2.4.19 -pre3
Linux kernel 2.4.19 -pre2
Linux kernel 2.4.19 -pre1
Linux kernel 2.4.19
Linux kernel 2.4.18 pre-8
Linux kernel 2.4.18 pre-7
Linux kernel 2.4.18 pre-6
Linux kernel 2.4.18 pre-5
Linux kernel 2.4.18 pre-4
Linux kernel 2.4.18 pre-3
Linux kernel 2.4.18 pre-2
Linux kernel 2.4.18 pre-1
Linux kernel 2.4.18 x86
Linux kernel 2.4.18
Linux kernel 2.4.17
Linux kernel 2.4.16
Linux kernel 2.4.15
Linux kernel 2.4.14
Linux kernel 2.4.13
Linux kernel 2.4.12
Linux kernel 2.4.11
Linux kernel 2.4.10
Linux kernel 2.4.9
Linux kernel 2.4.8
Linux kernel 2.4.7
Linux kernel 2.4.6
Linux kernel 2.4.5
Linux kernel 2.4.4
Linux kernel 2.4.3
Linux kernel 2.4.2
Linux kernel 2.4.1
Linux kernel 2.4 .0-test9
Linux kernel 2.4 .0-test8
Linux kernel 2.4 .0-test7
Linux kernel 2.4 .0-test6
Linux kernel 2.4 .0-test5
Linux kernel 2.4 .0-test4
Linux kernel 2.4 .0-test3
Linux kernel 2.4 .0-test2
Linux kernel 2.4 .0-test12
Linux kernel 2.4 .0-test11
Linux kernel 2.4 .0-test10
Linux kernel 2.4 .0-test1
Linux kernel 2.4
Linux kernel 2.2.25
Linux kernel 2.2.24
Linux kernel 2.2.23
Linux kernel 2.2.22
Linux kernel 2.2.21
Linux kernel 2.2.20
Linux kernel 2.2.19
Linux kernel 2.2.17
Linux kernel 2.2.16 pre6
Linux kernel 2.2.16
Linux kernel 2.2.15 pre20
Linux kernel 2.2.15 pre16
Linux kernel 2.2.15
Linux kernel 2.2.14
Linux kernel 2.2.13
Linux kernel 2.2.12
Linux kernel 2.2.11
Linux kernel 2.2.10
Linux kernel 2.2.9
Linux kernel 2.2.8
Linux kernel 2.2.7
Linux kernel 2.2.6
Linux kernel 2.2.5
Linux kernel 2.2.4
Linux kernel 2.2.3
Linux kernel 2.2.2
Linux kernel 2.2.1
Linux kernel 2.2
Leif M. Wright simplestmail.cgi 2.2.18
Not Vulnerable: Linux kernel 2.6.3
Linux kernel 2.6.2
Linux kernel 2.4.25
Linux kernel 2.4.24 -ow1
Linux kernel 2.4.24
Linux kernel 2.4.23 -ow2
Linux kernel 2.2.25


 

Privacy Statement
Copyright 2010, SecurityFocus