BugTraq
Re: [Full Disclosure] [Kil13r-SA-20060701-2] MoniWiki 1.1.1 Cross-Site Scripting Vulnerability Jul 02 2006 03:46PM
mac68k gmail com
Title:

[Kil13r-SA-20060701-2] MoniWiki 1.1.1 Cross-Site Scripting Vulnerability

Author:

Kil13r - http://www.kil13r.info/

Local / Remote:

Remote

Timeline:

2006/06/28 - Discovery

2006/06/28 - Vendor notification

2006/06/30 - Vendor notification

2006/07/01 - Release

2006/07/03 - Update

Affected version:

MoniWiki 1.1.1 or earlier

Not affected version:

MoniWiki 1.1.2-20060702 or after

Description:

MoniWiki is wiki software, but that has vulnerability.

In 2004, STG Security discovered MoniWiki XSS vulnerability and notified.

As a result, MoniWiki XSS vulnerability has been patched.

But, patch can be bypassed.

It can run arbitrary Javascript code by end user.

If victim execute arbitrary Javascript code, attacker can steal victim's cookie.

Proof of Concept code:

None

Proof of Concept example:

http://www.victim.com/wiki.php/"><script>alert(String.fromCharCode(88,83
,83,32,53580,49828,53944))</script>

Proof of Concept screenshot:

http://www.kil13r.info/sa/xss/moniwikixss.jpg

-

The Bird of Hermes is my name,

Eating my wings to make me tame.

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus