BugTraq
Vulnerability in Joomulus for Joomla Dec 25 2009 06:14PM
MustLive (mustlive websecurity com ua)
Hello Bugtraq!

I want to warn you about Cross-Site Scripting vulnerability in Joomulus
(mod_joomulus) plugin for Joomla. Which I found at 23.12.2009.

It is similar to XSS vulnerability in WP-Cumulus
(http://websecurity.com.ua/3665/), because it's using tagcloud.swf made by
author of WP-Cumulus. About millions of flash files tagcloud.swf which are
vulnerable to XSS attacks I mentioned in my article XSS vulnerabilities in 8
millions flash files (http://websecurity.com.ua/3789/).

XSS:

http://site/modules/mod_joomulus/tagcloud.swf?mode=tags&tagcloud=%3Ctags
%3E%3Ca+href='javascript:alert(document.cookie)'+style='font-size:+40pt'
%3EClick%20me%3C/a%3E%3C/tags%3E

Code will execute after click. It's strictly social XSS.

Also it's possible to conduct (like in WP-Cumulus) HTML Injection attack,
including in those flash files which have protection (in flash files or via
WAF) against javascript and vbscript URI in parameter tagcloud.

HTML Injection:

http://site/wp-content/plugins/wp-cumulus/tagcloud.swf?mode=tags&tagclou
d=%3Ctags%3E%3Ca+href='http://websecurity.com.ua'+style='font-size:+40pt
'%3EClick%20me%3C/a%3E%3C/tags%3E

Vulnerable are Joomulus 2.0 and previous versions.

I mentioned about this vulnerability at my site
(http://websecurity.com.ua/3801/).

Best wishes & regards,
MustLive
Administrator of Websecurity web site
http://websecurity.com.ua

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus