BugTraq
[ GLSA 201009-07 ] libxml2: Denial of Service Sep 21 2010 09:41PM
Stefan Behte (craig gentoo org)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201009-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: libxml2: Denial of Service
Date: September 21, 2010
Bugs: #280617
ID: 201009-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple Denial of Services vulnerabilities were found in libxml2.

Background
==========

libxml2 is a library to manipulate XML files.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-libs/libxml2 < 2.7.3-r2 >= 2.7.3-r2

Description
===========

The following vulnerabilities were reported after a test with the
Codenomicon XML fuzzing framework:

* Two use-after-free vulnerabilities are possible when parsing a XML
file with Notation or Enumeration attribute types (CVE-2009-2416).

* A stack consumption vulnerability can be triggered via a large
depth of element declarations in a DTD, related to a function
recursion (CVE-2009-2414).

Impact
======

A remote attacker could entice a user or automated system to open a
specially crafted XML document with an application using libxml2
resulting in a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libxml2 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libxml2-2.7.3-r2"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since August 30, 2009. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2009-2414
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2414
[ 2 ] CVE-2009-2416
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2416

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201009-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security (at) gentoo (dot) org [email concealed] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2010 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkyZJq0ACgkQuiczp+KMe7Q8oACgi3G0toRZpAdE00WmDaK53uzK
UQ4AoKx0yzIc8X0wdF2xS4Ipeausko8Q
=lqt2
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus