BugTraq
[Suspected Spam]XSS in Squirrelmail plugin 'Virtual Keyboard' <= 0.9.1 Oct 05 2010 08:55PM
Moritz Naumann (security moritz-naumann com)
Hi,

Squirrelmail plugin 'Virtual Keyboard' version 0.9.1 and lower is
vulnerable to cross site scripting (XSS).

The vkeyboard.php script fails to sanitize the value of HTTP GET
parameter 'passformname' which the script stores in a variable of the
same name and outputs (unmodified) into a HTML document later. As such,
it is possible to inject client-evaluated HTML and script code into the
output generated by the application.

For proof of concept, accessing the following location ([Base_URL]
refers to a Squirrelmail installation with a vulnerable version of the
'Virtual Keyboard' plugin) results in a javascript generated alert
windows reading 'XSS' popping up:
> [Base_URL]/plugins/vkeyboard/vkeyboard.php?passformname=%22%3E%3Cscript%
3Ealert%28%27XSS%27%29;%3C/script%3E%3Cscript%3E/*%20

'Virtual Keyboard' installations can be found using this 'Google dork':
> http://google.com/search?hl=en&safe=off&filter=0&q=inurl%3A%22vkeyboard.
php%22

This vulnerability was originally reported in early May 2010.
A suitable update fixing this issue, Virtual Keyboard v0.9.2 for
Squirrelmail 1.4.x, has been provided to the Squirrelmail developers and
me by Daniel Kobayashi Imori of Bastion Systems (the original developer
of this plugin) in early June 2010 - thanks Daniel! - and was attached
to the non-limited edition of this email which I sent to the Full
Disclosure mailing list.

The Squirrelmail team has not yet made it to update this plugin in their
repository at
http://squirrelmail.org/plugin_view.php?id=159
so far, so this is the first public release I am aware of.

Thanks for reading,

Moritz Naumann
--
Naumann IT Security Consulting
Samariterstr. 16
10247 Berlin
Germany

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus