BugTraq
HTB22870: SQL Injection in GRAND Flash Album Gallery wordpress plugin Mar 08 2011 09:53AM
advisory htbridge ch
Vulnerability ID: HTB22870
Reference: http://www.htbridge.ch/advisory/sql_injection_in_grand_flash_album_galle
ry_wordpress_plugin.html
Product: GRAND Flash Album Gallery wordpress plugin
Vendor: Sergey Pasyuk ( http://codeasily.com/ )
Vulnerable Version: 0.55
Vendor Notification: 22 February 2011
Vulnerability Type: SQL Injection
Risk level: High
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)

Vulnerability Details:
The vulnerability exists due to failure in the "/wp-content/plugins/flash-album-gallery/lib/hitcounter.php" script to properly sanitize user-supplied input in "pid" variable.
Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.

The following PoC is available:

http://[host]/wp-content/plugins/flash-album-gallery/lib/hitcounter.php?
pid=SQL_CODE_HERE

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus