BugTraq
[ MDVSA-2012:156 ] inn Oct 02 2012 12:58PM
security mandriva com
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDVSA-2012:156
http://www.mandriva.com/security/
_______________________________________________________________________

Package : inn
Date : October 2, 2012
Affected: 2011.
_______________________________________________________________________

Problem Description:

A security issue was identified and fixed in ISC INN:

The STARTTLS implementation in INN's NNTP server for readers, nnrpd,
before 2.5.3 does not properly restrict I/O buffering, which allows
man-in-the-middle attackers to insert commands into encrypted sessions
by sending a cleartext command that is processed after TLS is in place,
related to a plaintext command injection attack, a similar issue to
CVE-2011-0411 (CVE-2012-3523).

The updated packages have been upgraded to inn 2.5.3 which is not
vulnerable to this issue.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-3523
https://www.isc.org/software/inn/2.5.3article
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2011:
0fdfb8541c9dde983ada87a196ecc45a 2011/i586/inews-2.5.3-0.1-mdv2011.0.i586.rpm
60e226fec04eaa464dbe7a5f2c593713 2011/i586/inn-2.5.3-0.1-mdv2011.0.i586.rpm
47326ed2fb59ccdbaa5e6328e09deb95 2011/i586/inn-devel-2.5.3-0.1-mdv2011.0.i586.rpm
e42adcff2587362f39488faf96f9c496 2011/SRPMS/inn-2.5.3-0.1.src.rpm

Mandriva Linux 2011/X86_64:
f4824198caa2bbc317a14fd592bff6f7 2011/x86_64/inews-2.5.3-0.1-mdv2011.0.x86_64.rpm
7ac20f123163d73f1dc78757a6c1ed88 2011/x86_64/inn-2.5.3-0.1-mdv2011.0.x86_64.rpm
eb416372f4e3cebd236a53c89c83eec5 2011/x86_64/inn-devel-2.5.3-0.1-mdv2011.0.x86_64.rpm
e42adcff2587362f39488faf96f9c496 2011/SRPMS/inn-2.5.3-0.1.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iD8DBQFQarmImqjQ0CJFipgRAg6IAKDmIgEoq7aEzwTd7EkcUIoenjxywACfSozW
acETQYOqxMaOxt6dNMShDpc=
=d6j2
-----END PGP SIGNATURE-----

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus