A Reflected XSS in Easy2Map version 1.2.9 WordPress plugin Oct 04 2015 06:12PM
ibemed gmail com
Vulnerability title: A Reflected XSS in Easy2Map version 1.2.9 WordPress plugin
CVE: CVE-2015-7668
Vendor: Steven Ellis
Product: Easy2Map
Affected version: 1.2.9
Fixed version: 1.3.0
Reported by: Ibéria Medeiros

Vulnerability Details:
It was discovered that no protection against a reflected XSS attacks was implemented, resulting in an attacker being able to retrive user data from end user, such as session cookies.

The Easy2Map version 1.2.9 WordPress plugin is vulnerable to 1 reflected XSS vulnerability.
The includes/MapPinImageSave.php file is vulnerable to Cross-site.scripting (XSS) attacks via $_GET["map_id"] parameter.

System affected:
Any system that access to a web site developed by WordPress CMS version 4.3.1 or earlier and uses the Easy2Map version 1.2.9 or earlier.

item: "Increased data sanitization logic, for improved plugin security."

Update to Easy2Map version 1.3.0 plugin.

Disclosure Timeline:
Vendor notification: September 22, 2015
Vendor fixed vulnerability: October 4, 2015
Public advisory: October 4, 2015
Public disclosure: October 4, 2015

[ reply ]


Privacy Statement
Copyright 2010, SecurityFocus