BugTraq
Ajax Load More Local File Inclusion vulnerability Aug 15 2016 04:21PM
Summer of Pwnage (lists securify nl)
------------------------------------------------------------------------

Ajax Load More Local File Inclusion vulnerability
------------------------------------------------------------------------

Burak Kelebek, July 2016

------------------------------------------------------------------------

Abstract
------------------------------------------------------------------------

It was discovered that the Ajax Load More WordPress plugin is vulnerable
to Local File Inclusion. This issue can potentially be exploited to run
arbitrary PHP code. In order to do so, the attacker must be able to
place an arbitrary PHP file on the target system. The malicious file
must have the .php extension.

------------------------------------------------------------------------

OVE ID
------------------------------------------------------------------------

OVE-20160712-0034

------------------------------------------------------------------------

Tested versions
------------------------------------------------------------------------

This issue was succesfully tested on the Ajax Load More - Infinite
Scroll WordPress Plugin version 2.11.1.

------------------------------------------------------------------------

Fix
------------------------------------------------------------------------

This issue is fixed in version 2.11.2

------------------------------------------------------------------------

Details
------------------------------------------------------------------------

https://sumofpwn.nl/advisory/2016/ajax_load_more_local_file_inclusion_vu
lnerability.html

------------------------------------------------------------------------

Summer of Pwnage (https://sumofpwn.nl) is a Dutch community project. Its
goal is to contribute to the security of popular, widely used OSS
projects in a fun and educational way.

[ reply ]


 

Privacy Statement
Copyright 2010, SecurityFocus