Wireless Security
Re: passing usb wifi to VMs on OS X Aug 26 2010 02:36PM
Robin Wood (robin digininja org) (1 replies)
Got it sussed. I renamed
/System/Library/Extensions/RT2870USBWirelessDriver.kext and rebooted.
Virtualbox happy passed the device on to the guest then. Now got Linux
running and it gets the device. All the tools are detecting it but it
isn't getting any data but at least I'm a step further now.


On 20 August 2010 22:45,  <josh (at) zombietango (dot) com [email concealed]> wrote:
> It should just be a logically named kext file located in /System/Library/Extensions. Pull that and restart.
> When I was using MacOSX for security work, I had good luck with a couple usb wifi adapters and Vmware fusion using either a custom linux build or Backtrack. Never tried it with VB though.
> ZT
> ------Original Message------
> From: Robin Wood
> Sender: listbounce (at) securityfocus (dot) com [email concealed]
> To: wifisec (at) securityfocus (dot) com [email concealed]
> Subject: Re: passing usb wifi to VMs on OS X
> Sent: Aug 20, 2010 12:31 PM
> On 18 August 2010 22:22, Robin Wood <robin (at) digininja (dot) org [email concealed]> wrote:
>> I've got a new Alfa 2W card, the one with the Ralink chipset. OS X
>> detects it and it works fine in managed mode but I'd like to pass it
>> through to my VirtualBox VMs. When I try I get an error about the
>> device being in use by someone else. How can I get OS X to detach the
>> device from its apps so I can re-attach it to the VM?
> I've tried various solutions but no luck so far. The one I thought
> would work was having the VM have focus when plugging in the card to
> see if it tried to capture it but no luck.
> I did install the drivers originally. Is there a good way to zap
> drivers once installed? I've not see any good software/driver remover
> tools yet.
> Robin
> Sent via BlackBerry from T-Mobile

[ reply ]
Re: passing usb wifi to VMs on OS X Aug 26 2010 06:19PM
Thomas d'Otreppe (tdotreppe gmail com)


Privacy Statement
Copyright 2010, SecurityFocus