Ruby CVE-2017-14033 Buffer Underrun Vulnerability
Ruby is prone to a buffer-underrun vulnerability.
An attacker can exploit this issue to cause denial-of-service conditions. Due to the nature of this issue, arbitrary code execution may be possible but this has not been confirmed.
The following versions are affected:
Ruby 2.2.7 and prior versions are affected.
Ruby 2.3.4 and prior versions are affected.
Ruby 2.4.1 and prior versions are affected.