Perl CVE-2017-12814 Stack Based Buffer Overflow Vulnerability

Perl is prone to a stack-based buffer overflow vulnerability because it fails to properly bounds-check user-supplied input.

An attacker can exploit this issue to execute arbitrary code in the context of the vulnerable application. Failed exploit attempts will likely result in denial-of-service conditions.

Perl prior to 5.24.3-RC1 and 5.26.x prior to 5.26.1-RC1 are vulnerable; other versions may also be affected.


Privacy Statement
Copyright 2010, SecurityFocus