Oniguruma Multiple Memory Corruption Vulnerabilities

Bugtraq ID: 101244
Class: Boundary Condition Error
CVE: CVE-2017-9226
CVE-2017-9224
Remote: Yes
Local: No
Published: May 22 2017 12:00AM
Updated: Oct 30 2018 02:00PM
Credit: lxxxxfdh
Vulnerable: RubyGems RubyGems 2.4.1
RubyGems RubyGems 2.4
Redhat Enterprise Linux 7
Redhat Enterprise Linux 6
+ Trustix Secure Enterprise Linux 2.0
+ Trustix Secure Linux 2.2
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.0
Redhat Enterprise Linux 5
Redhat Collections for Red Hat Enterprise Linux 0
PHP PHP 7.1.5
PHP PHP 7.1.4
PHP PHP 7.1.1
PHP PHP 7.1
PHP PHP 7.1.3
PHP PHP 7.1.2
Oracle Solaris 11.4
Oracle Solaris 11.3
kkos oniguruma 6.2
IBM Flex System Manager 1.3.2 0
IBM Flex System Manager 1.3.4.0
IBM Flex System Manager 1.3.3.0
IBM Flex System Manager 1.3.2.1
Not Vulnerable: PHP PHP 7.1.7
PHP PHP 5.6.31
Oracle Solaris 11.4 SRU 2
Oracle Solaris 11.3 LSU 36
kkos oniguruma 6.3.0


 

Privacy Statement
Copyright 2010, SecurityFocus