Leon J Breedt Pam-PGSQL Remote SQL Injection Vulnerability

Leon J Breedt's 'pam-pgsql' is a PAM authentication module to be used with PostgreSQL.

'pam-pgsql' is prone to a vulnerability which will allow SQL queries to be manipulated via any medium which requires a user to authenticate(HTTP, SSH, telnet, etc). Data that is included in SQL query strings is not adequately sanitized.

It may be possible for malicious users to modify the structure of SQL queries.

This issue allows the user to access database resources that would normally be restricted, which may in turn provide an opportunity for the attacker to exploit other vulnerabilities that exist in the server. The attacker may be able to exploit this issue to gain unauthorized access to the host.


 

Privacy Statement
Copyright 2010, SecurityFocus