Icecast Server Base64 Authorization Request Remote Buffer Overflow Vulnerability

It has been reported that Icecast server may be prone to a remote buffer overflow vulnerability when processing an excessively long base64 authentication request. A remote attacker could execute arbitrary code in the context of the server leading to unauthorized access.

This issue is reported to exist in Icecast 2.0.0, however, it is possible that previous versions are affected as well.


 

Privacy Statement
Copyright 2010, SecurityFocus