Delta Electronics WPLSoft Multiple Security Vulnerabilities

Delta Electronics WPLSoft is prone to the following security vulnerabilities:

1. A stack-based buffer-overflow vulnerability
2. A heap-based buffer-overflow vulnerability
3. A remote code-execution vulnerability

An attacker can exploit these issues to execute arbitrary code in the context of the application, or cause a denial-of-service condition.

Delta Industrial WPLSoft Version 2.45.0 and prior versions are vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus