Librelp CVE-2018-1000140 Stack Based Buffer Overflow Vulnerability

Bugtraq ID: 104510
Class: Design Error
CVE: CVE-2018-1000140
Remote: Yes
Local: No
Published: Mar 23 2018 12:00AM
Updated: Mar 23 2018 12:00AM
Credit: Bas van Schaik, and Kevin Backhouse, rsyslog
Vulnerable: RSyslog librelp 1.2.14
RSyslog librelp 1.2
RSyslog librelp 1.1.1
Redhat Enterprise Linux Workstation 7
Redhat Enterprise Linux Workstation 6
Redhat Enterprise Linux Server - Update Services for SAP Solutions 7.4
Redhat Enterprise Linux Server - Update Services for SAP Solutions 7.3
Redhat Enterprise Linux Server - Update Services for SAP Solutions 7.2
Redhat Enterprise Linux Server - TUS 7.4
Redhat Enterprise Linux Server - TUS 7.3
Redhat Enterprise Linux Server - TUS 7.2
Redhat Enterprise Linux Server - TUS 6.6
Redhat Enterprise Linux Server - Extended Update Support 7.5
Redhat Enterprise Linux Server - Extended Update Support 7.4
Redhat Enterprise Linux Server - Extended Update Support 7.3
Redhat Enterprise Linux Server - Extended Update Support 6.7
Redhat Enterprise Linux Server - AUS 7.4
Redhat Enterprise Linux Server - AUS 7.3
Redhat Enterprise Linux Server - AUS 7.2
Redhat Enterprise Linux Server - AUS 6.6
Redhat Enterprise Linux Server (for IBM Power LE) - Update Services for SAP Solutions 7.
Redhat Enterprise Linux Server (for IBM Power LE) - Update Services for SAP Solutions 7.
Redhat Enterprise Linux Server 7
Redhat Enterprise Linux Server 6
Redhat Enterprise Linux for Scientific Computing 7
Redhat Enterprise Linux for Scientific Computing 6
Redhat Enterprise Linux for Power, little endian - Extended Update Supp 7.5
Redhat Enterprise Linux for Power, little endian - Extended Update Supp 7.4
Redhat Enterprise Linux for Power, little endian - Extended Update Supp 7.3
Redhat Enterprise Linux for Power, little endian 7
Redhat Enterprise Linux for Power, big endian - Extended Update Support 7.5
Redhat Enterprise Linux for Power, big endian - Extended Update Support 7.4
Redhat Enterprise Linux for Power, big endian - Extended Update Support 7.3
Redhat Enterprise Linux for Power, big endian - Extended Update Support 6.7
Redhat Enterprise Linux for Power, big endian 7
Redhat Enterprise Linux for Power, big endian 6
Redhat Enterprise Linux for Power 9 7
Redhat Enterprise Linux for IBM z Systems - Extended Update Support 7.5
Redhat Enterprise Linux for IBM z Systems - Extended Update Support 7.4
Redhat Enterprise Linux for IBM z Systems - Extended Update Support 7.3
Redhat Enterprise Linux for IBM z Systems - Extended Update Support 6.7
Redhat Enterprise Linux for IBM z Systems 7
Redhat Enterprise Linux for IBM z Systems 6
Redhat Enterprise Linux for IBM System z (Structure A) 7
Redhat Enterprise Linux for ARM 64 7
Redhat Enterprise Linux EUS Compute Node 7.5
Redhat Enterprise Linux EUS Compute Node 7.4
Redhat Enterprise Linux EUS Compute Node 7.3
Redhat Enterprise Linux EUS Compute Node 6.7
Redhat Enterprise Linux Desktop 7
Not Vulnerable: RSyslog librelp 1.2.16


 

Privacy Statement
Copyright 2010, SecurityFocus