Check Point VPN-1 ASN.1 Buffer Overflow Vulnerability

Bugtraq ID: 10820
Class: Boundary Condition Error
CVE: CVE-2004-0699
Remote: Yes
Local: No
Published: Jul 28 2004 12:00AM
Updated: Jul 12 2009 06:16AM
Credit: Discovery of this vulnerability is credited to Mark Dowd and Neel Mehta of the Internet Security Systems X-Force.
Vulnerable: Check Point Software VSX FireWall-1 GX
Check Point Software VPN-1/Firewall-1 VSX NG with AI Release 2
Check Point Software VPN-1/Firewall-1 VSX NG with AI Release 1
Check Point Software VPN-1/Firewall-1 VSX 2.0.1
Check Point Software VPN-1 VSX 2.0.1
Check Point Software SSL Network Extender
Check Point Software SecuRemote NG with Application Intelligence R56
Check Point Software SecuRemote 4.1
Check Point Software SecuRemote 4.0
Check Point Software SecureClient NG with Application Intelligence R56
Check Point Software SecureClient 4.1
Check Point Software SecureClient 4.0
Check Point Software Provider-1 NG with Application Intelligence R55
Check Point Software Provider-1 NG with Application Intelligence R54
Check Point Software NG-AI R55W
Check Point Software NG-AI R55
Check Point Software NG-AI R54
Check Point Software FireWall-1 VSX NG with Application Intelligence
Check Point Software FireWall-1 VSX 2.0.1
Check Point Software FireWall-1 Next Generation FP3
Check Point Software FireWall-1 GX 2.5
Check Point Software FireWall-1 GX 2.0
Not Vulnerable:


 

Privacy Statement
Copyright 2010, SecurityFocus